Technology content trusted in North America and globally since 1999
8,420 Reviews & Articles | 64,473 News Posts

DiRT 4 will be released on macOS and Linux on 28th March

Posted Mar 25, 2019 @ 18:27 CDT | Stock Ticker(s): NASDAQ:AMD, NASDAQ:INTC, NASDAQ:NVDA

Feral Interactive today announced that DiRT 4, the acclaimed off-road and rally racing game, will be released on macOS and Linux on 28th March. Originally developed and published by Codemasters for PC and consoles, DiRT 4 is the latest of the studio's world-renowned racing games to be brought to macOS and Linux by Feral, following the success of DiRT Rally, GRID Autosport, and F1 2017.

DiRT 4 delivers the intense thrill of all-terrain motorsport in an electrifying mix of disciplines. Players will hurtle through point-to-point Rally races, compete in events from the official FIA World Rallycross Championship, push trucks and buggies to the limit in exhilarating Landrush battles, and put their precision steering skills to the test in Joyride challenges.

A new DiRT 4 trailer is available now on the Feral Interactive YouTube channel.

DiRT 4 is available to pre-order now from the Feral Store for $59.99 / EURO 44.99 / EURO 54.99.

macOS system requirements:

DiRT 4 will be supported on the following Macs:

  • All 13" MacBook Pros released since 2016
  • All 15" MacBook Pros released since Mid 2012 with a 1GB graphics card or better
  • All 21.5" iMacs released since Late 2013 with a 1.8GHz i5 processor or better
  • All 27" iMacs released since Late 2013
  • Late 2012 models with an NVIDIA GeForce GTX 675MX or NVIDIA GeForce GTX 680MX graphics card are also supported
  • All 27" iMac Pros released since Late 2017
  • All Mac Pros released since Late 2013
  • All Mac minis released since 2018

Linux system requirements:

  • OS: Ubuntu 18.04
  • Processor: Intel Core i3-3225 3.3ghzâ€<
  • GPU: 2GB NVIDIA 680, 2GB AMD R9 285 (GCN 3rd Gen and above) or betterâ€< (See notes for more details)
  • System RAM: 4 GB RAM
  • Storage: 39GB

Additional Notes:

  • Requires Vulkan
  • NVIDIA graphics cards require driver version 418.43 or later
  • AMD graphics cards require Mesa drivers version 18.3.4 or later
  • AMD GCN 3rd Gen graphics cards include the R9 285, 380, 380X, Nano, Fury, and Fury X
  • Other modern drivers and distributions are expected to work but are not officially supported

Related Tags