TweakTown
Tech content trusted by users in North America and around the world
6,137 Reviews & Articles | 39,429 News Posts
Weekly Giveaway: Win an Antec Case, PSU and Cooler (Global Entry!)

Ask the Experts Question: My computer seems to be frozen on the setup page, help!

Question asked by Bryant from United States | | Motherboards Content | Posted:
Ask Question | Comment | Font Size: AA

I just got a used ASUS Crosshair IV computer, and cannot get it to go past the setup page. I have an older Dell computer, but is nothing like this one. What do I need to know?

Hi Bryant,

 

From what you've explained, it sounds like there is something wrong with your setup in terms of hardware or installation. My first step would be to completely disassemble the main components - CPU, motherboard, RAM - and reassemble very carefully.

 

TweakTown image asktheexperts/1/1/112_01_my_computer_seems_to_be_frozen_on_the_setup_page_help.jpg

 

Making sure that the CPU is seated properly and securely, the same goes for the RAM. If it continues to have the same problems, try one stick of RAM at a time (you should have 2-4 sticks I'm guessing). If you've got a second PC, or a friend with similar components, try out your GPU, PSU, RAM and whatever else you can on their system to see if one or more of your components are faulty.

 

Failing all of this - get a friend to look at it, or take it in to a local computer shop to get it looked at - the motherboard could be faulty and they're one of the harder things to test without a spare.

 

Hopefully it all goes well!

Related Tags

Do you get our Ask the Experts RSS feed? Get It!

- Sadly we cannot answer every question. There is a friendly community in our forums though who may well be able to help with your tech question!

Got an opinion on this Q&A? Post a comment below!

Latest Tech News Posts

View More News Posts

Forum Activity

View More Forum Posts

Press Releases

View More Press Releases