Tech content trusted by users in North America and around the world
7,349 Reviews & Articles | 53,802 News Posts

World of Warcraft is experiencing further network issues

Blizzard are experiencing issues once again with their servers
By: Chris Smith | Gaming News | Posted: Dec 3, 2014 3:21 am

Just three days ago, we reported on Blizzard Entertainment's apparent DDoS/Lag issues happening within their game servers globally - seeing some players being unable to log in for up to 30 minutes, reports of friend lists not functioning and customers experiencing up to 5,000ms of in-game latency.

 

world_of_warcraft_experiencing_further_network_issues_020

 

This issue was fixed just mere hours after the story was reported, however in today's news, Blizzard have issued multiple statements across their Customer Service Twitter account alongside their Battle.Net client claiming of Authentication and log in issues - mainly based around their North American server cluster.

 

world_of_warcraft_experiencing_further_network_issues_019

 

Their Twitter reports issues ranging from in-game latency problems to authentications and log in services failing.

 

Usually we don't see too many issues with Blizzard's offerings - however since the release of their latest expansion, Warlords of Draenor, there have seemingly been more and more problems popping up. Let's hope this doesn't become a staple for Blizzard as we'd hate to see them tarnish their good reputation.

 

We will continue to report as the story may develop.

NEWS SOURCES:Twitter.com

Related Tags

Got an opinion on this news? Post a comment below!
Subscribe to our Newsletter

Latest News Posts

View More News Posts

Forum Activity

View More Forum Posts

Press Releases

View More Press Releases
loading